Call us: +44 (0)330 043 1625

Wednesday 12th November 2025

Issue affecting my.sonassi.com

We are aware of an issue affecting my.sonassi.com currently.

We're working to resolve the issue as soon as possible.


Update: 04:33 We're continuing to work on the issue, we have no further update at this time.


Update : All systems are functioning correctly