We are experiencing a power outage within our data centres located in Manchester (DC6 and DC7) which may affect some services.
We are currently coordinating with our building managers to restore systems as quickly as possible.
*****Update 18:43
Power has been restored. We're checking services and ensuring services are online..
*****Update 19:27
All Services are online. We're continuing to monitor the situation.
if you are encountering issues, please raise an Emergency ticket where our engineers will looking into any issues.