Friday 7th July 2023

Network Network performance issues

Disruption

We're aware of a disruption to our services and our team are currently investigating.

Updates will follow as soon as possible.

  • Update (10:55): Services should now be restored, but our team are continuing to monitor this closely.