Saturday 17th December 2022

Network Network performance issues

Disruption

We're aware of a disruption to our services and our network team are currently investigating.

Updates will follow as soon as possible.

update 11:47 GMT.

This issue is currently stable as of 11:15. Engineers are continuing to monitor.