Saturday 13th March 2021

Network Network Interruption

Disruption We're aware of a disruption to our services and our network team are currently investigating.

  • Update (14:39): We're investigating an issue at one of our datacentres

  • Update (16:31): We can confirm all services should now be back online and further investigation on the issue will be carried out.