Tuesday 25th August 2020

Support Portal Support Portal Issue

Disruption

  • Update (00:02): Our engineers are currently investigating an issue with the Support Portal. The portal will appear offline currently for all customers.
  • Update (03:04): Service has been restored, a post-mortem will be provided shortly.