Friday 18th May 2018

Network Interruption

Disruption

  • Update (12:51): We are investigating a potential network interruption.
  • Update (12:56): Upon inspection, there was a very brief drop in service from an upstream carrier. We are still investigating, but the matter looks to be resolved almost immediately.