Monday 18th December 2017

Network Network Interruption

Disruption (18/12/2017)

  • Update (21:11): A large volume DOS attack has been detected and mitigation has been activated - we are investigating further now.
  • Update (22:44): The attack is still ongoing and mitigation is still active. Customer services are believed to be wholly unaffected at present.